Setting up Ipv6 over v4 tunneling on Mikrotik RouterOs

Hi, There!

This is a guide on how to set up your MikroTik and clients on your LAN to be able to use ipv6 over an ipv4 tunnel.


show what packages are enabled / disabled

/system package print

if ipv6 has a “X” next to it, run this:

/system package enable ipv6
/system reboot

then check again

/system package print

now for some configuring, I used the Hurricane Electric IPv6 tunneling service for my tunnel, on the tunnels page you will find the information relevant to your tunnel. Make sure you have the following:

  1. Server IPv4 Address
  2. Server IpV6 Address
  3. Client IpV4 Address
  4. Client IpV6 Address
  5. routed /64
/interface 6to4 add comment="Hurricane Electric IPv6 Tunnel Broker" disabled=no local-address= mtu=1280 name=sit1 remote-address=
/ipv6 route add comment="" disabled=no distance=1 dst-address=2000::/3 gateway= scope=30 target-scope=10
/ipv6 address add address= advertise=yes disabled=no eui-64=no interface=sit1

Now those commands have been run, give your PC a few mins, then run ipconfig (or ifconfig if on ubuntu), you should see something like this:

ifconfig
eth0 Link encap:Ethernet HWaddr 00:xx:xx:xx:xx:xx
inet addr:10.xx.xx.xx Bcast:10.xx.xx.xx Mask:255.255.0.0
inet6 addr: 2001:470:xxx:xxx:xxx:xxx:xxx:xxx/64 Scope:Global
inet6 addr: 2001:470:xxx:xxx:xxx:xxx:xxx:xxx/64 Scope:Global
inet6 addr: fe80::xxx:xxx:xxx:xxx/64 Scope:Link

if you do, try running the command

ping ipv6.ainsey11.com

If you get a response, this is all working!! congratulations! 🙂

Leave a Reply

Your email address will not be published. Required fields are marked *